[solved] authentication problem with comments

[solved] authentication problem with comments

Postby marcotics on Tue Dec 06, 2011 12:32 pm

I have one strange problem with commenting on my own site, and i'm not quite sure what causes it.

If i go to my own site from within the admin interface, i arrive at my own site Authenticated. So i cannot enter a name when i comment, because my username is already there, and there is no more input field. Submitting a comment is impossible, as it gives me an error ' You should at least give your name or nickname.'

Since i use the remember comment data plugin, there is a way around, by logging out, commenting with any given name, say John Doe, deleting that comment after logging in and commenting again as Authenticated. Strangely it has remembered John Doe, so the comment is now left as John Doe, with my usernames avatar.

As i say, strange. I hope someone understands what i mean :lol:
Last edited by marcotics on Sun Dec 11, 2011 12:47 pm, edited 1 time in total.
marcotics
 
Posts: 42
Joined: Wed Mar 17, 2010 1:02 pm
LifeType Version: 1.2.11

Re: authentication problem with comments

Postby jondaley on Wed Dec 07, 2011 11:38 pm

Hmm.. I've seen that bug before. I wonder how I fixed it. It might be that you need a new version of the remembercommentdata plugin? Otherwise, the bug is in the template, are you using the default commentform template, or does your template have its own?
jondaley
Lifetype Expert
 
Posts: 6169
Joined: Thu May 20, 2004 6:19 pm
Location: Pittsburgh, PA, USA
LifeType Version: 1.2.11 devel branch

Re: authentication problem with comments

Postby marcotics on Thu Dec 08, 2011 2:16 pm

jondaley wrote:Hmm.. I've seen that bug before. I wonder how I fixed it. It might be that you need a new version of the remembercommentdata plugin? Otherwise, the bug is in the template, are you using the default commentform template, or does your template have its own?


I have just downloaded the plugin again, so it must be the latest version. Lifetype keeps telling me there is a newer one, so i guess there is a problem somewhere in the plugin, but probably just in the version number noted. As for the commentform.template, my template does not include one, so i us the one located in the template/default directory.
marcotics
 
Posts: 42
Joined: Wed Mar 17, 2010 1:02 pm
LifeType Version: 1.2.11

Re: authentication problem with comments

Postby jondaley on Sat Dec 10, 2011 12:24 pm

Hrm, the latest version is 20111027, and my installation of lifetype says that is the most up-to-date version, so it doesn't look like a bug in the release process (I I originally figured that I hadn't uploaded the latest release to sourceforge), but that version is uploaded there.

Ah, wait a minute. sourceforge says it was uploaded 10/27, but that file is the old version. That's weird.

I've reuploaded the plugin. And yes, that bug was the one I fixed back in October, so the new version will solve your problem.
jondaley
Lifetype Expert
 
Posts: 6169
Joined: Thu May 20, 2004 6:19 pm
Location: Pittsburgh, PA, USA
LifeType Version: 1.2.11 devel branch

Re: authentication problem with comments

Postby marcotics on Sun Dec 11, 2011 12:46 pm

jondaley wrote:Hrm, the latest version is 20111027, and my installation of lifetype says that is the most up-to-date version, so it doesn't look like a bug in the release process (I I originally figured that I hadn't uploaded the latest release to sourceforge), but that version is uploaded there.

Ah, wait a minute. sourceforge says it was uploaded 10/27, but that file is the old version. That's weird.

I've reuploaded the plugin. And yes, that bug was the one I fixed back in October, so the new version will solve your problem.


And it did. Thanks again.
marcotics
 
Posts: 42
Joined: Wed Mar 17, 2010 1:02 pm
LifeType Version: 1.2.11


Return to Other Problems

cron