Repeated login problem

Repeated login problem

Postby mike.lischke on Mon Mar 28, 2011 2:39 pm

Hey there,

until 8 days ago my Lifetype installation worked fine but today I found a strange problem I need help with. I can successfully login to the backend but for any action (other than simply reading my existing postings) I'm brought back to the login page, where I can again successfully login. This will bring me back to the overview page, where the same process starts again if I want to do anything useful there.

I suspected a problem with the browser since I upgraded to FF 4 recently, but also Safari shows the same symptoms and I believe one of our writers (who reported it to me) has IE on her box. So I guess that means it's not the browser. I also tried to repair all tables in the db, just in case, to no avail.

Any help, pointers, hints etc. are welcome to solve this problem.

Thank you,

Mike
mike.lischke
 
Posts: 5
Joined: Mon Mar 28, 2011 2:33 pm
LifeType Version: not yet

Re: Repeated login problem

Postby mike.lischke on Wed Mar 30, 2011 3:38 am

Nobody with at least marginal help? That's unfortunate, especially as I have to solve this quickly (as so often). Seems i have to switch to a more reliable solution then.

Mike
mike.lischke
 
Posts: 5
Joined: Mon Mar 28, 2011 2:33 pm
LifeType Version: not yet

Re: Repeated login problem

Postby martinh on Thu Mar 31, 2011 11:05 am

Do you host diffrent domains on your webserver? Is it a single webserver or one with an loadbalancer or reverse proxy?
martinh
 
Posts: 175
Joined: Wed Aug 01, 2007 7:32 am
Location: Heidelberg, Germany
LifeType Version: 1.2.11

Re: Repeated login problem

Postby mike.lischke on Thu Mar 31, 2011 1:58 pm

Hey Martin,

thanks for taking the time to reply. The server in question is a multi domain host, though the LifeType installation is just serving a blog like flow of articles into an otherwise hand make website (the only one on this host, all others use Joomla! but not LifeType in any way). My login problem is purely for the backend. I still can read all my previous postings and embed them into my website. And, just to make it clear, this worked until a bit more than a week ago for a long time.

I also thought about a possible hack of the site but I do not see any indications that would be the case. The lifetype installation is simply acting strange and I can for the life of me not find out why.

I can do whatever is necessary on the server to get this up again. I can even directly access any db table, file, whatever. Just need a hint where to look. If that matters: this is a Win 2008 R2 Webserver with IIS7 and PHP as ISAPI module.

Thanks,

Mike
mike.lischke
 
Posts: 5
Joined: Mon Mar 28, 2011 2:33 pm
LifeType Version: not yet

Re: Repeated login problem

Postby jondaley on Thu Mar 31, 2011 9:55 pm

Was PHP (or any module) recently upgraded?

What version of LifeType are you using?

Are you getting any errors or it is just acting like the session expired?

Perhaps PHP's session directory is having some permission issues? Is there plenty of disk space free on all drives?
jondaley
Lifetype Expert
 
Posts: 6169
Joined: Thu May 20, 2004 6:19 pm
Location: Pittsburgh, PA, USA
LifeType Version: 1.2.11 devel branch

Re: Repeated login problem

Postby mike.lischke on Fri Apr 01, 2011 4:05 am

Hi jondaley,

thanks for trying to help.

jondaley wrote:Was PHP (or any module) recently upgraded?


No updates, whatoever.

jondaley wrote:What version of LifeType are you using?


Since I could not really login I did not know the version (hence it is not set in my profile here), but now I tried harder and found version.php which says I'm on 1.1.6_r4742, which is probably pretty old, since I set this up only for a blog like embedded style.

jondaley wrote:Are you getting any errors or it is just acting like the session expired?


Things got worse, now that I started testing various things. I cleared the Temp folder of the lifetype installation and explicitely set full permissions for normal users on that box. Not sure if it was already so before I did that (did not test, damn), but now I get a server error 500 if I touch anything from the lifetype installation. So I had to exclude it entirely from the website to not let it drag offline by this problem.

jondaley wrote:Perhaps PHP's session directory is having some permission issues? Is there plenty of disk space free on all drives?


Yes, enough disk space there. The session dir is empty but I set it to full access for normal users on the box too. No change though.

Mike
mike.lischke
 
Posts: 5
Joined: Mon Mar 28, 2011 2:33 pm
LifeType Version: not yet

Re: Repeated login problem

Postby jondaley on Tue Apr 05, 2011 12:29 am

If you look in the server error log, what does it say is causing the 500 error?
My guess would be the permissions on the tmp directory.
jondaley
Lifetype Expert
 
Posts: 6169
Joined: Thu May 20, 2004 6:19 pm
Location: Pittsburgh, PA, USA
LifeType Version: 1.2.11 devel branch

Re: Repeated login problem

Postby mike.lischke on Tue Apr 05, 2011 2:57 am

That's what I thought too, so I temporarily gave "everyone" full access. However, this did not solve the problem. Actually, I was surprised that I could not easily find which user IIS7 runs under and hence needs to give rights on the websites folders. Finally I found IUSR to be the one that needs proper rights, in particular write access for certain temp folders. The 500 error is probably caused by the fact that I cleand LT's temp folder, assuming it would recreate the structure in it automatically.

But anyway, this was only the finaly reason I needed to finally port this last hand-made website over to a CMS (Joomla! in my case), so this issue is no longer an issue of mine. LT is now out of the game for me.

Thanks anyway,

Mike
mike.lischke
 
Posts: 5
Joined: Mon Mar 28, 2011 2:33 pm
LifeType Version: not yet

Re: Repeated login problem

Postby jondaley on Wed Apr 06, 2011 12:08 pm

The tmp directory structure is recreated automatically, so that isn't the problem. Good luck with Joomla.
jondaley
Lifetype Expert
 
Posts: 6169
Joined: Thu May 20, 2004 6:19 pm
Location: Pittsburgh, PA, USA
LifeType Version: 1.2.11 devel branch


Return to Other Problems

cron