Blank Summary Page

Blank Summary Page

Postby freeblogplace on Thu Jul 22, 2010 8:29 am

I've got a really weird issue. Most of the time, the summary page for my blog network works just fine. If you visit my site, freeblogplace.com, there is a 80% (gut guess) that it will work and a 20% chance that you will simply get a blank page. I've searched and searched for issues that have been resolved like this but I've not been able to find anything.

When the condition is occurring the following error shows up in my php error log:

[22-Jul-2010 07:18:57] PHP Fatal error: Call to undefined function _smarty_tplfunc_6b1afe353bb8eb3e9e235c71d2769876_0() in /opt/websites/freeblogplace.com/lifetype-1.2.10/class/template/smarty/Smarty.class.php on line 1828

If I clear out the tmp directory with all of the smarty files, it "can" result in the page displaying but then the condition returns. The strange thing is that it seems to go away on its own. This is starting to drive me a little nuts. Can somebody point me to the right direction to solve this? At this point, I've only made minor changes to the templates for summary.php and I've not started to really customize it to make it look the way I want it to look so none of the php has been changed. I am using the latest version of lifetype 1.2.10 and I have the template pack and the plugin pack installed.
freeblogplace
 
Posts: 4
Joined: Thu Jul 22, 2010 8:21 am
LifeType Version: 1.2.10

Re: Blank Summary Page

Postby freeblogplace on Thu Jul 22, 2010 10:38 am

Here is some additional information regarding this issue. I finally figured out how to reproduce it and then correct it temporarily...

The summary page changes to a blank page following a new sign up. Everything works fine, somebody completes the registration process to obtain a blog and boom, the summary page is blank.

To get it back, I rm * the contents of tmp/summary/ and then immediately go to my site. The page is then no longer blank. If I refresh, it returns to being blank BUT if I login and then log out, the summary page continues working just fine until the next person signs up.
freeblogplace
 
Posts: 4
Joined: Thu Jul 22, 2010 8:21 am
LifeType Version: 1.2.10

Re: Blank Summary Page

Postby jondaley on Fri Jul 23, 2010 4:17 pm

Hrm, that is odd. And the login/logout thing seems odd too. What version of PHP are you running?
jondaley
Lifetype Expert
 
Posts: 6169
Joined: Thu May 20, 2004 6:19 pm
Location: Pittsburgh, PA, USA
LifeType Version: 1.2.11 devel branch

Re: Blank Summary Page

Postby freeblogplace on Fri Jul 23, 2010 6:12 pm

The php version is 5.2.10. I'm also running with APC 3.1.3p1.
freeblogplace
 
Posts: 4
Joined: Thu Jul 22, 2010 8:21 am
LifeType Version: 1.2.10

Re: Blank Summary Page

Postby jondaley on Tue Jul 27, 2010 1:33 pm

Hrm, that was the wrong answer. :)

Your php version is fine, and I hadn't heard of this problem happening on php5 before.

There is a recent post on the german forum, and he also says he is running php5. These sorts of problems are really hard to track down.
You could try upgrading smarty on your own - or even downgrading it. You could grab the smarty directory from a previous lifetype release (I forget when we upgraded smarty, maybe in 1.2.8 or maybe later. I'd think 1.2.7 would be a safe bet.
jondaley
Lifetype Expert
 
Posts: 6169
Joined: Thu May 20, 2004 6:19 pm
Location: Pittsburgh, PA, USA
LifeType Version: 1.2.11 devel branch

Re: Blank Summary Page

Postby freeblogplace on Tue Jul 27, 2010 3:27 pm

Thanks for something to try out :) I grabbed LT 1.2.7 and swapped its class/template/smarty directory into the 1.2.10 release. The good news is that summary.php sort of works, the bad news is that after logging in some of the screens work fine and others fail. Here's a snippet of my php error log:

PHP Fatal error: Smarty error: [in admin/newpost.template line 141]: syntax error: unrecognized tag 'check_perms' (Smarty_Compiler.class.php, line 590) in /opt/websites/freeblogplace.com/lifetype-1.2.10/class/template/smarty_new/Smarty.class.php on line 1093
PHP Fatal error: Smarty error: [in toni/main.template line 9]: syntax error: unrecognized tag 'pager' (Smarty_Compiler.class.php, line 590) in /opt/websites/freeblogplace.com/lifetype-1.2.10/class/template/smarty_new/Smarty.class.php on line 1093

This is really driving me nuts. For now, I've swapped smarty back to the one included in the release.

And now I've got an issue with the admin screens. I login, and then choose one of the blogs to manage and it logs me out and dumps me back to /. I just don't get it. I've not really hacked anything up it's basically a straight release with all of the plugins and templates. I successfully used lifetype in 2007 for another project, (mycoupons.com) and it worked just great. This implementation is something really straight forward and I've got these crazy problems.
freeblogplace
 
Posts: 4
Joined: Thu Jul 22, 2010 8:21 am
LifeType Version: 1.2.10

Re: Blank Summary Page

Postby jondaley on Tue Jul 27, 2010 10:37 pm

Ok, I looked it up. Smarty was upgraded in 1.2.9, so you should try the 1.2.8 version. That was a fairly big release, though I'm not sure about those errors you're getting.
You should erase the entire smarty directory, and not just copy over it.

The logout problem sounds like a mod_security sort of problem, thinking you are a hacker or something like that.

Oh, I forgot to mention it before - can you disable the APC and see if that changes/fixes anything?
jondaley
Lifetype Expert
 
Posts: 6169
Joined: Thu May 20, 2004 6:19 pm
Location: Pittsburgh, PA, USA
LifeType Version: 1.2.11 devel branch


Return to Other Problems

cron