Spam Comments

Spam Comments

Postby Kekerusey on Sat Jun 07, 2014 1:42 pm

Hi,

I have installed lifetype (lifetype-1.2.12_r7211) and have a spam problem.

I mailed before creating my userid and got a helpful reply none of which I have actioned yet (fully intend to) but, in the meantime I got so frustrated with the level of spam comments I was getting that I turned comments off completely (Administration --> General --> comments_enabled = No). This didn't work ... I have had something like 50 spam comments since.

This I don't understand.

Keke
Last edited by Kekerusey on Mon Jun 09, 2014 6:39 am, edited 1 time in total.
Kekerusey
 
Posts: 2
Joined: Sat Jun 07, 2014 1:35 pm
LifeType Version: lifetype-1.2.12_r721

Re: Spam Comments

Postby Kekerusey on Mon Jun 09, 2014 6:39 am

Hi,

I know I should install the spam protection I was told about but I've switched comments off and (as far as I can tell) switched captcha on ... I mean surely the spam comments should stop? I was hoping to catch a break i.e. switch comments off, install protection, open them up again to test, rinse and repeat.

Yet they seem to be coming thicker and faster than ever ... is this a bug in Lifetype itself? As things presently stand I reckon I'm going to have to go back to WordPress (something I really don't want to do).

Keke
Kekerusey
 
Posts: 2
Joined: Sat Jun 07, 2014 1:35 pm
LifeType Version: lifetype-1.2.12_r721

Re: Spam Comments

Postby jondaley on Mon Jun 09, 2014 1:33 pm

I tried to reply via email, but your anti-spam thing blocked me, and I don't like those anti-spam verifiers, as they aren't practical if everyone implemented them, (if I used that system, your system wouldn't have gotten the verification email, etc) and I didn't get around to coming to see if you posted to the forum.

As for turning off comments, you likely changed the default status for new blogs:
Adminstration->general->comments_enabled->Enable comments for new blogs by default. [Default = Yes]
rather than the existing blog:
control center->blog settings->enable comments

The second one is the one you want.

I'm not sure what you mean by a bug in lifetype regarding spams - do you mean that there aren't real spammers posting the comments? That isn't happening, for sure.

It sounds like you aren't sure whether you installed the captcha properly (do you see the captcha on the comment form?), but since captchas are obsolete, I wouldn't recommend installing that plugin anyway. hiddeninput is my favorite (I wrote it...) and it has stopped almost all of my spam for the last seven(?) years. I also started using plain moderation, though spiced up the plugin with some smarts regarding prior posts (prior spammers get penalized, prior good commenters can bypass moderation), and that works really well for me.

I assume the rate of comments went up on your blog because once spammers smell blood, they attack with a vengeance.
jondaley
Lifetype Expert
 
Posts: 6169
Joined: Thu May 20, 2004 6:19 pm
Location: Pittsburgh, PA, USA
LifeType Version: 1.2.11 devel branch


Return to Configuration and Installation

cron