New Install - WYSIWYG Problems

New Install - WYSIWYG Problems

Postby Dogen on Wed Dec 14, 2011 3:11 pm

I've installed LifeType twice now on two different machines and have the same problem in each install.

In IE 7 the TinyMCE WYSIWYG editor fails to display. I am only able to use the text editor. It almost works correctly in FireFox 8. HOWEVER, the "Insert Media" and "Toggle 'More...' link" links error out as "False" with the following in the URL bar:

javascript:tinyMCE.execInstanceCommand('mce_editor_0','mceinsertresource',true);
javascript:tinyMCE.execInstanceCommand('mce_editor_0','mcemoremore');

As our department is an MS only shop and few sections have been upgraded to IE8, this presents a serious problem.

Any help would be greatly appreciated!!!
Dogen
 
Posts: 3
Joined: Wed Dec 14, 2011 3:02 pm
LifeType Version: 1.2.11

Re: New Install - WYSIWYG Problems

Postby jondaley on Thu Dec 15, 2011 12:05 pm

I think that might have already been fixed in the latest version. Try downloading the "nightly" build (link below) I use firefox 8 and it works there.

Oh - you are talking about the text links below the window? I'm not sure why they are there, we should remove them. The icons in the toolbar work fine, and those links are redundant.

http://lifetype.net/snapshots/core-bran ... latest.zip
jondaley
Lifetype Expert
 
Posts: 6169
Joined: Thu May 20, 2004 6:19 pm
Location: Pittsburgh, PA, USA
LifeType Version: 1.2.11 devel branch

Re: New Install - WYSIWYG Problems

Postby jondaley on Thu Dec 15, 2011 12:23 pm

Ah, and I also hadn't noticed that the non-visual editor has been broken. Probably everyone uses the visual editor. Tonight's build will fix the non-visual editor.
jondaley
Lifetype Expert
 
Posts: 6169
Joined: Thu May 20, 2004 6:19 pm
Location: Pittsburgh, PA, USA
LifeType Version: 1.2.11 devel branch

Re: New Install - WYSIWYG Problems

Postby Dogen on Thu Dec 15, 2011 12:59 pm

Hi Jon,

I installed the latest version per your message. I'm now running: lifetype-1.2_r7162

However, the WYSIWYG editor problem remains in IE7 and when I do a file version check, I'm getting the following errors. I overwrote everything but config.properties.php

The following files do not match the expected contents:
class/file/fileuploads.class.php
class/file/unpacker/pclzip.lib.php
class/mail/phpmailer/language/phpmailer.lang-en.php
class/mail/phpmailer/class.phpmailer.php
class/mail/phpmailer/class.smtp.php
class/controller/sequentialcontroller.class.php
class/net/requestgenerator.class.php
class/net/modrewriterequestgenerator.class.php
class/summary/controller/registrationcontroller.class.php
class/summary/dao/summarystatsconstants.class.php
class/summary/net/summaryrequestgenerator.class.php
class/summary/view/doblogregistrationview.class.php
class/summary/view/blogtemplatechooserview.class.php
class/summary/action/activeaccountaction.class.php
class/summary/action/summaryaction.class.php
class/gallery/getid3/module.audio.wavpack.php
class/gallery/getid3/module.tag.id3v2.php
class/xml/tree/Tree.php
class/xml/tree/Node.php
class/xml/parser/Parser.php
class/cache/Memcached_Client/memcached-client.php
class/dao/permission.class.php
class/dao/userdata/joomlauserdataprovider.class.php
class/dao/userdata/baseuserdataprovider.class.php
class/dao/userdata/wbbuserdataprovider.class.php
class/dao/userdata/vbb3userdataprovider.class.php
class/dao/userdata/phpbb2userdataprovider.class.php
class/dao/userdata/ldapuserdataprovider.class.php
class/dao/permissions.class.php
class/dao/userstatus.class.php
class/dao/bayesianfilterinfos.class.php
class/dao/bayesiantokens.class.php
class/database/pdb/datadict/pdbmysqldatadict.class.php
class/database/pdb/datadict/pdbbasedatadict.class.php
class/database/pdb/datadict/pdbfielddescobject.class.php
class/database/pdb/drivers/pdbmysqldriver.class.php
class/database/pdb/drivers/pdbdriverbase.class.php
class/database/pdb/drivers/pdbrecordset.class.php
class/data/validator/rules/emailformatrule.class.php
class/data/validator/rules/datetimerule.class.php
class/data/jalalicalendar.class.php
class/data/jalalicalendarstrings.properties.php
class/data/stringutils.class.php
class/data/plogcalendar.class.php
class/data/htmlcalendar.class.php
class/data/inputfilter.class.php
class/view/admin/adminsitelocaleslistview.class.php
class/view/admin/admincreateblogview.class.php
class/view/admin/adminsiteuserslistview.class.php
class/view/admin/adminarticlecategorieslistview.class.php
class/view/admin/admineditpostview.class.php
class/view/admin/adminnewbloguserview.class.php
class/view/admin/adminsitetemplateslistview.class.php
class/template/smarty/plugins/modifier.stars.php
class/template/smarty/plugins/modifier.utf8_wordwrap.php
class/template/menu/menurenderer.class.php
class/action/admin/adminaddbloguseraction.class.php
class/action/admin/adminaddarticlecategoryajaxaction.class.php
class/action/admin/admineditpostsaction.class.php
class/action/admin/adminpoststatsaction.class.php
class/action/admin/adminupdatepermissionaction.class.php
class/action/admin/adminadminblogselectaction.class.php
class/action/admin/admineditarticlecategoriesaction.class.php
class/action/admin/admindoregisterblogaction.class.php
class/action/admin/admineditlinksaction.class.php
class/action/admin/adminresourcesgroupaction.class.php
class/action/admin/adminpermissionrequiredaction.class.php
class/action/admin/adminaddarticlecategoryaction.class.php
class/action/admin/admineditcommentsaction.class.php
class/action/admin/adminaddpermissionaction.class.php
class/action/admin/adminmarkcommentaction.class.php
class/action/admin/admineditpermissionaction.class.php
class/action/admin/admineditglobalarticlecategoriesaction.class.php
class/action/admin/adminadduseraction.class.php
class/action/admin/adminblogcategoriesaction.class.php
class/action/admin/adminaddresourceaction.class.php
class/action/admin/admineditlinkcategoriesaction.class.php
class/action/viewresourceaction.class.php
Dogen
 
Posts: 3
Joined: Wed Dec 14, 2011 3:02 pm
LifeType Version: 1.2.11

Re: New Install - WYSIWYG Problems

Postby Dogen on Fri Dec 16, 2011 12:32 pm

Hi Jon - I upgraded to the latest core from the 16th (lifetype-1.2_r7165) but I'm still not having any luck getting IE7 to use the WYSIWYG editor.

I'm also still getting the list of files in /class that supposedly do not match the version even though I overwrote everything with the files from the 16th.
Dogen
 
Posts: 3
Joined: Wed Dec 14, 2011 3:02 pm
LifeType Version: 1.2.11

Re: New Install - WYSIWYG Problems

Postby jondaley on Sat Dec 17, 2011 12:04 pm

It might be the case that the nightly builds don't do the filechecker thing properly, so that probably isn't a problem.

I don't have IE7 to test on. I thought that was a particularly bad version, and that most people skipped it? I am not sure if I am going to be able to help you on that one. IE9 is already released, isn't it? Is there a reason you can't upgrade to 8?
jondaley
Lifetype Expert
 
Posts: 6169
Joined: Thu May 20, 2004 6:19 pm
Location: Pittsburgh, PA, USA
LifeType Version: 1.2.11 devel branch


Return to Configuration and Installation

cron