TinyMCE disappeared

TinyMCE disappeared

Postby -J- on Tue Feb 08, 2011 3:15 am

Hi,

I've made several updates yesterday and I just noticed today tinyMCE disappeared from the "new post" and "edit post" pages..

The post are now displayed in HTML

I've tried several things, even overwriting all the files (but I still get the same "version errors" as reported here viewtopic.php?f=7&t=9667)

Any idea / suggestion to sort this out ?

Thanks in advance for your help,

-J-
-J-
 
Posts: 116
Joined: Sun Apr 03, 2005 4:02 pm

Re: TinyMCE disappeared

Postby italian_user on Tue Feb 08, 2011 4:16 am

-J- wrote:Hi,

I've made several updates yesterday and I just noticed today tinyMCE disappeared from the "new post" and "edit post" pages..

The post are now displayed in HTML

I've tried several things, even overwriting all the files (but I still get the same "version errors" as reported here viewtopic.php?f=7&t=9667)

Any idea / suggestion to sort this out ?

Thanks in advance for your help,

-J-


Sometimes I have the same problem with Safari in Mac.
Try to change browser. Often with Firefox everything works well.
italian_user
 
Posts: 193
Joined: Mon Apr 03, 2006 1:37 pm
LifeType Version: 1.2.11

Re: TinyMCE disappeared

Postby -J- on Tue Feb 08, 2011 6:24 am

unfortunately I've tried with firefox & chrome, but it doesn't work
-J-
 
Posts: 116
Joined: Sun Apr 03, 2005 4:02 pm

Re: TinyMCE disappeared

Postby jondaley on Tue Feb 08, 2011 9:32 am

what does "several updates" mean? Do you mean updates to the posts, or updating the code and/or plugins?
If you have files in red, you need to fix those - I thought you said you had managed to copy them over properly last time.
jondaley
Lifetype Expert
 
Posts: 6169
Joined: Thu May 20, 2004 6:19 pm
Location: Pittsburgh, PA, USA
LifeType Version: 1.2.11 devel branch

Re: TinyMCE disappeared

Postby -J- on Tue Feb 08, 2011 9:37 am

I updated the code. When I realized I had too much versions problems, I renamed class/ -> class2/ and reuploaded the class/ directory from the latest files. But it still says the versions are wrong?? (that's super weird)
-J-
 
Posts: 116
Joined: Sun Apr 03, 2005 4:02 pm

Re: TinyMCE disappeared

Postby -J- on Tue Feb 08, 2011 1:46 pm

Thank you very much Jon for your help. I've been using lifetype for years and you've always been here to help !

I deactivated the plugins but still no change

I don't know if it can help, but when I activate firebug it returns me an error message:

tinyMCE.addToLang is not a function
[Stopper sur une erreur] (374 out of range 134)


Can it help ?
-J-
 
Posts: 116
Joined: Sun Apr 03, 2005 4:02 pm

Re: TinyMCE disappeared

Postby jondaley on Tue Feb 08, 2011 3:01 pm

I'd like to get the red version errors away first, and then we can work on tinymce. It is possible that there is an error only in a french language file.

Is the list of files all of the files in the class directory, or just a handful?

You should try turning on the FTP "binary" setting and see if that helps - some ftp clients and servers modify the files when they are copied if it thinks they are text, and using "binary" will force it to leave them alone.
jondaley
Lifetype Expert
 
Posts: 6169
Joined: Thu May 20, 2004 6:19 pm
Location: Pittsburgh, PA, USA
LifeType Version: 1.2.11 devel branch

Re: TinyMCE disappeared

Postby -J- on Wed Feb 09, 2011 8:24 am

Thanks for your reply. I tried to overwrite the files again and again but couldn't make it work.

So I moved the whole install to anothe directory, uploaded the latest tar.gz, opened it on the server, and replaced the config and gallery files... no more problems with the versions ! I got a nice green "All files are correct". Hurray !

Now, after a ctrl+F5 tinyMCE seems to be working on firefox, but not on IE (I received several complains from users). I thought ctrl+F5 would work on IE too, but I've still got an error in tiny_mce_gzip.js line 132, char 4

Any idea ?
-J-
 
Posts: 116
Joined: Sun Apr 03, 2005 4:02 pm

Re: TinyMCE disappeared

Postby jondaley on Sat Feb 12, 2011 12:25 am

I've heard that there is a bug in IE for tinymce's plugins for insertresource and insertvideo (or maybe audio). I haven't looked into yet - Mark Wu is the developer who is working on it currently. I don't think he reads these forums, but you could check out the plog-svn mailing list, and see the bit of discussion about it, and then ask him what the next steps are. I probably won't have time to look at it for a while myself. And debugging on IE is always a pain, so I try to avoid it if I can.
jondaley
Lifetype Expert
 
Posts: 6169
Joined: Thu May 20, 2004 6:19 pm
Location: Pittsburgh, PA, USA
LifeType Version: 1.2.11 devel branch

Re: TinyMCE disappeared

Postby marcotics on Tue Feb 15, 2011 3:00 pm

I upgraded from .10 to .11, and my tinymce disappeared aswell. I tried clearing the cache, with both IE and Firefox, but nothing. Hard refreshing won't work, in either browser. Checked the settings for WYSIWYG, turned it off and on, but still nothing.

I didn't find how to upgrade, so i just uploaded new files (changed files zip package). Something wrong there?
marcotics
 
Posts: 42
Joined: Wed Mar 17, 2010 1:02 pm
LifeType Version: 1.2.11

Re: TinyMCE disappeared

Postby martinh on Wed Feb 16, 2011 3:46 am

I had the same problem. I deleted the hole old TinyMCE folder and uploaded the new files.
martinh
 
Posts: 175
Joined: Wed Aug 01, 2007 7:32 am
Location: Heidelberg, Germany
LifeType Version: 1.2.11

Re: TinyMCE disappeared

Postby jondaley on Wed Feb 16, 2011 10:14 pm

Strange. I know for sure that it works on firefox. What version of FF are you using?
I have upgraded a number of installations for various people, and haven't heard of this problem.

Are there any errors, other than tinymce not showing?

Line 132 of tiny_mce_gzip.js contains code that should only run on IE, so if it is running on firefox, that is definitely the problem.

uploading the entire folder is better than just upgrading the files. Do you have any custom files in the tinymce folder?
Is your blog in english?

If you go to the administration->misc->file check (I can't remember if that is the exact name, maybe called version?) and you run the file check does it show any files in red?
jondaley
Lifetype Expert
 
Posts: 6169
Joined: Thu May 20, 2004 6:19 pm
Location: Pittsburgh, PA, USA
LifeType Version: 1.2.11 devel branch

Re: TinyMCE disappeared

Postby marcotics on Thu Mar 03, 2011 3:23 pm

If i download the latest version, the full package this time, and overwrite everything, would that crash my site, or will i loose my posts as it will probably be considered a fresh install, creating the tables again, wipe out my settings and posts?

In other words, what's the safest way of updating everything, not just the changed files?

I did some plugins that had me modify files, so not everything is 100% as it was originally, but if the blog is fully working on 1.2.11, i'll do the changes again. Also, the site uses Dutch locale.
marcotics
 
Posts: 42
Joined: Wed Mar 17, 2010 1:02 pm
LifeType Version: 1.2.11

Re: TinyMCE disappeared

Postby jondaley on Thu Mar 03, 2011 3:54 pm

Installing fresh files and not running the wizard won't do anything to your database. If you have uploaded pictures, you should not overwrite the gallery folder. If you have made customizations to your templates, you'll want the template folder as well. If you haven't modified, or don't mind re-applying any changes to the admin, summary or rss templates, it is the best to overwrite those folders.

What plugins ask for modifications to the core code?

There was a guy who was using the french locale who also complained about tinymce, and historically, we've seen a problem or two regarding tinymce's languages and lifetype's languages, so that could be the problem. Though I'm more concerned about the red/changed files.
jondaley
Lifetype Expert
 
Posts: 6169
Joined: Thu May 20, 2004 6:19 pm
Location: Pittsburgh, PA, USA
LifeType Version: 1.2.11 devel branch

Re: TinyMCE disappeared

Postby marcotics on Thu Mar 03, 2011 5:07 pm

jondaley wrote:What plugins ask for modifications to the core code?


To be honoust, i can't find those notes anywhere. I know i applied more plugins than i use. Probably some plugin said to modify core files, and i found out the plugin wouldn't work, so i trew away the notes.

For the time being, i restored everything to .10, since the WYSIWYG editor is important for me.
Version check on this .10 istallation (probably the file check you recommended) says
class/summary/action/dofinishregister.class.php
templates/default/commentform.template

are not as expected. those are the only 2. I know several plugins regarding comments state alterations to commentform.template. Why i altered dofinishregister.class.php, i can't remember, but i have a fuzzy feeling it was stated by a mod aswell.

This weekend i'll overwrite everything except the gallery and the template i use. After that, i'll get back to you about this, and i'll try to see if setting the locale back from dutch to english makes any difference.

Thanks in advance
marcotics
 
Posts: 42
Joined: Wed Mar 17, 2010 1:02 pm
LifeType Version: 1.2.11

Next

Return to Configuration and Installation

cron