Un francophone de plus ... avec ..... un probleme de plus :)

Un francophone de plus ... avec ..... un probleme de plus :)

Postby stunyos on Mon Feb 25, 2008 4:28 pm

Bonjour à tou(te)s

Ravi de rejoindre la petite communauté francophone de lifetype qui tend à grossir... bref voici mon souci que je n'ai pu regler malgres mon parcours du forum et de toute l'aide l'anglophone (ceci-étant je suis loin d'etre bilingue !)

Lifetype est tout à fait ce que je recherche et ce qu'il me faut pour permettre aux utilisateurs de mon site de disposer de leurs propres blogs hebergés par mes soins...
ceci étant il y a un point que je n'arrive pas à resoudre qui concerne l'editeur html qui se trouve dans le module d'administration lorsque l'on poste ou edite un article. certaines occurences HTML ne sont pas reconnues et sont tout bonnements supprimées mais il y en a au moins une qui m'est (et l'est à mes utilisateurs) néccéssaire : background

je m'explique :

le
Code: Select all
<table background="http://example.com/image.png">
<tr>
<td>
<h2>Sommaire</h2>
<br />
Bienvenue sur mon blog
</td></tr></table>


est automatiquement retranscrit une fois la validation effectuée par :


le
Code: Select all
<table>
   <tbody>
      <tr>
         <td>
         <h2>Sommaire</h2><br />
         Bienvenue sur mon blog </td>
      </tr>
   </tbody>
</table>


Quelqu'un aurait-il une solution pour inclure une image de fond dans un post ????

Merci par avance
stunyos
 
Posts: 11
Joined: Mon Feb 25, 2008 3:43 pm

Postby help_me44 on Mon Feb 25, 2008 5:37 pm

Moi il dénature la page des fois avec des "Suite de l'article". j'ai du demandé a un bloggeur d'aller éditer ses articles et d'enlever les "<div>" je crois et remplacer par "<br>" ... sauf que ya pas de rapport donc plutot enlever les "<p>" et mettre des "<br>".

Oui oui je sais "<br />" :)
help_me44
 
Posts: 38
Joined: Fri Dec 28, 2007 9:24 pm

Postby stunyos on Mon Feb 25, 2008 5:38 pm

oui mais bon ça change pas mon probleme :s
stunyos
 
Posts: 11
Joined: Mon Feb 25, 2008 3:43 pm

Postby help_me44 on Mon Feb 25, 2008 5:42 pm

Essaie :

<span style="background: url('http://tonimage')"><span>lolllll</span> </span>


Moi il me le garde et m'affiche un truc mais jvai tester plus encore !!
help_me44
 
Posts: 38
Joined: Fri Dec 28, 2007 9:24 pm

Postby help_me44 on Mon Feb 25, 2008 5:43 pm

Ouai ca marche faut juste rectifier le code html un peu après car il a tendance a ressortir du span. Tu veux un exemple ?
help_me44
 
Posts: 38
Joined: Fri Dec 28, 2007 9:24 pm

Postby help_me44 on Mon Feb 25, 2008 5:46 pm

tiens regarde

Le premier article : ya un fond qui clignote, c'est un .gif que j'ai mis.

<span style="background: url('http://_blog.gif')">Ppppdspfpdspfsdds sdfdsfsdfsdfsdfsdfsdfsdfsdfsdfsdfsdfsdfsdfs<br />
dfsdfsdfsdfsdfsdfsdfsdfsdfsdfsdfsdfsdf sdfsdfsdfsdfsdfsdfsdfsdfsdf
<p>
sdfsdsd^f^sdf^sd^f^sd^fs^df^sd^f^sdf
</p>
<p>
dsfsdfsdfsdf
</p>
</span>
Last edited by help_me44 on Mon Feb 25, 2008 6:08 pm, edited 1 time in total.
help_me44
 
Posts: 38
Joined: Fri Dec 28, 2007 9:24 pm

Postby stunyos on Mon Feb 25, 2008 5:50 pm

nickel merci
stunyos
 
Posts: 11
Joined: Mon Feb 25, 2008 3:43 pm

Re: Un francophone de plus ... avec ..... un probleme de plus :)

Postby golgoth on Sun Mar 16, 2008 5:56 pm

Bonsoir

J'ai constaté, que dans l'interface administration il était possible d'interdire des balises et d'en autoriser.

Pour ton histoire de background favorise les <div> aux tableaux.
Code: Select all
<h2>Sommaire</h2>
<p class="welcome">Bienvenue sur mon blog</p>


et dans ta feuille de style

Code: Select all
.welcome {
  background: url(images/mon_image.png} no-repeat;
  height:auto;
  padding:2px;
  color:#333;
  font-size:1em;
}


@+ :wink:
golgoth
 
Posts: 13
Joined: Tue Jan 22, 2008 7:06 am


Return to French

cron