Problem with final Release

Problem with final Release

Postby cactusman on Wed Mar 21, 2007 2:44 am

Hi !

I got some problems with the final release of lifetype-1.2 (in locale with Easy-PHP) that I didn't have with the lifetype-1.2-beta1ls version.

I got a lot of error messages, either during the install and after that.
I got this kind of message:

Code: Select all
Exception message: unlink(./tmp/summary\%%49^491^491576AE%%registerstep0.template.php): No such file or directory
Error code: 2
-- Backtrace --
c:\program files\easyphp1-8\www\blogs\class\template\smarty\internals\core.write_file.php(44): unlink
c:\program files\easyphp1-8\www\blogs\class\template\smarty\internals\core.write_compiled_resource.php(29): smarty_core_write_file
...


I also wonder if you plan to release french local files? I had a look but the new stuff for version 1.2 in admin forlder are quiet difficult to translate...

Thanks
cactusman
 
Posts: 73
Joined: Sun Feb 25, 2007 4:55 am
Location: Japan
LifeType Version: 1.2.8

Postby phunkphorce on Wed Mar 21, 2007 2:57 am

Did you try cleaning the tmp/ folder before starting the installation? That should help.

With regards to the French locale, none of the developer speaks French. It is up to you French-speaking users to help us and translate, why don't you leave a message in the French forums below and, see if somebody else is interested and then share the work?
phunkphorce
Lifetype Expert
 
Posts: 9028
Joined: Mon Aug 25, 2003 6:34 am
Location: Suomessa

Postby cactusman on Wed Mar 21, 2007 3:43 am

Unfortunately it doesn't work I still have the same problem.

For the translation, I will leave a message on the fench forum.
cactusman
 
Posts: 73
Joined: Sun Feb 25, 2007 4:55 am
Location: Japan
LifeType Version: 1.2.8

Postby phunkphorce on Wed Mar 21, 2007 3:48 am

Does this error prevent you from installing LT at all?

Please remember that if you're upgrading from one of the betas, all you have to do is overwrite your current files with the ones in the 1.2-final package. There is no need to run the installation again, I guess I forgot to modify that in the announcement posted to lifetype.net (http://www.lifetype.net/blog/lifetype-d ... 2-released)
phunkphorce
Lifetype Expert
 
Posts: 9028
Joined: Mon Aug 25, 2003 6:34 am
Location: Suomessa

Postby phunkphorce on Wed Mar 21, 2007 3:59 am

And about the French locale, you don't have to write it from scratch. Although we have split locale files in two in Lifetype 1.2 so that we can save some memory when loading the blog front-end (it only requires about 200 locale strings/lines), you can start with the one that was part of LifeType 1.1. We can help you split the file in two and even tell you which strings are missing by comparing it to the current English one.

There should be less than 100 new strings, that's about an hour job.
phunkphorce
Lifetype Expert
 
Posts: 9028
Joined: Mon Aug 25, 2003 6:34 am
Location: Suomessa

Postby cactusman on Wed Mar 21, 2007 4:00 am

Actually I didn't upgrade from the beta version, I have just installed the release version as a new one.
I can install it but I got the same display problem in the summay, the other menus and in the administration interface.

As I work mostly on doing a totally different design, I can't do anything...

I left a message on the french forum and I start the french files now :D
Yeah I noticed for the 2 parts no problem. Just some technical words are difficults for me lol (like Drop-down list)
cactusman
 
Posts: 73
Joined: Sun Feb 25, 2007 4:55 am
Location: Japan
LifeType Version: 1.2.8

Postby xtremelead on Wed Mar 21, 2007 6:00 am

I've got the same errors
I did upgrade from the beta, overwriting all files like phunkphorce explained.

The following errors appear on the blog page

Exception message: unlink(./tmp/1\%%76^76B^76BABA72%%main.template.php): No such file or directory
Error code: 2
-- Backtrace --
path_to_site\class\template\smarty\internals\core.write_file.php(44): unlink
path_to_site\class\template\smarty\internals\core.write_compiled_resource.php(29): smarty_core_write_file
path_to_site\class\template\smarty\Smarty.class.php(1433): smarty_core_write_compiled_resource
path_to_site\class\template\smarty\Smarty.class.php(1263): cachedtemplate._compile_resource
path_to_site\class\template\cachedtemplate.class.php(48): smarty.fetch
path_to_site\class\view\smartyview.class.php(257): cachedtemplate.fetch
path_to_site\class\view\blogview.class.php(286): smartyview.render
path_to_site\class\view\defaultview.class.php(100): blogview.render
path_to_site\class\controller\controller.class.php(379): defaultview.render
path_to_site\index.php(51): blogcontroller.process

Exception message: unlink(./tmp/1\%%8F^8FF^8FFD2255%%header.template.php): No such file or directory
Error code: 2
-- Backtrace --
path_to_site\class\template\smarty\internals\core.write_file.php(44): unlink
path_to_site\class\template\smarty\internals\core.write_compiled_resource.php(29): smarty_core_write_file
path_to_site\class\template\smarty\Smarty.class.php(1433): smarty_core_write_compiled_resource
path_to_site\class\template\smarty\Smarty.class.php(1869): cachedtemplate._compile_resource
path_to_site\class\template\template.class.php(136): smarty._smarty_include
path_to_site\tmp\1\%%76^76B^76BABA72%%main.template.php(4): cachedtemplate._smarty_include
path_to_site\class\template\smarty\Smarty.class.php(1265): include
path_to_site\class\template\cachedtemplate.class.php(48): smarty.fetch
path_to_site\class\view\smartyview.class.php(257): cachedtemplate.fetch
path_to_site\class\view\blogview.class.php(286): smartyview.render
path_to_site\class\view\defaultview.class.php(100): blogview.render
path_to_site\class\controller\controller.class.php(379): defaultview.render
path_to_site\index.php(51): blogcontroller.process

Exception message: unlink(./tmp/1\%%AE^AE3^AE3D0A70%%post.template.php): No such file or directory
Error code: 2
-- Backtrace --
path_to_site\class\template\smarty\internals\core.write_file.php(44): unlink
path_to_site\class\template\smarty\internals\core.write_compiled_resource.php(29): smarty_core_write_file
path_to_site\class\template\smarty\Smarty.class.php(1433): smarty_core_write_compiled_resource
path_to_site\class\template\smarty\Smarty.class.php(1869): cachedtemplate._compile_resource
path_to_site\class\template\template.class.php(136): smarty._smarty_include
path_to_site\tmp\1\%%76^76B^76BABA72%%main.template.php(12): cachedtemplate._smarty_include
path_to_site\class\template\smarty\Smarty.class.php(1265): include
path_to_site\class\template\cachedtemplate.class.php(48): smarty.fetch
path_to_site\class\view\smartyview.class.php(257): cachedtemplate.fetch
path_to_site\class\view\blogview.class.php(286): smartyview.render
path_to_site\class\view\defaultview.class.php(100): blogview.render
path_to_site\class\controller\controller.class.php(379): defaultview.render
path_to_site\index.php(51): blogcontroller.process

Exception message: unlink(./tmp/1\%%46^464^464701F7%%footer.template.php): No such file or directory
Error code: 2
-- Backtrace --
path_to_site\class\template\smarty\internals\core.write_file.php(44): unlink
path_to_site\class\template\smarty\internals\core.write_compiled_resource.php(29): smarty_core_write_file
path_to_site\class\template\smarty\Smarty.class.php(1433): smarty_core_write_compiled_resource
path_to_site\class\template\smarty\Smarty.class.php(1869): cachedtemplate._compile_resource
path_to_site\class\template\template.class.php(136): smarty._smarty_include
path_to_site\tmp\1\%%76^76B^76BABA72%%main.template.php(18): cachedtemplate._smarty_include
path_to_site\class\template\smarty\Smarty.class.php(1265): include
path_to_site\class\template\cachedtemplate.class.php(48): smarty.fetch
path_to_site\class\view\smartyview.class.php(257): cachedtemplate.fetch
path_to_site\class\view\blogview.class.php(286): smartyview.render
path_to_site\class\view\defaultview.class.php(100): blogview.render
path_to_site\class\controller\controller.class.php(379): defaultview.render
path_to_site\index.php(51): blogcontroller.process


Clearing the tmp folder and crtl-f5 in the browser does nof fix this.

these errors also appear on the admin gui. when I ctrl-f5 here, the errors disappear, but each link I click a new error appears and I ctrl-f5 again.
xtremelead
 
Posts: 29
Joined: Fri May 12, 2006 1:14 am

Postby cactusman on Wed Mar 21, 2007 7:12 am

I've just finished the french translation.

What shall I do now. Maybe somebody want to check that? Could be usefull for others users...

I still have the same problem... :(
cactusman
 
Posts: 73
Joined: Sun Feb 25, 2007 4:55 am
Location: Japan
LifeType Version: 1.2.8

Postby jondaley on Wed Mar 21, 2007 7:24 am

It looks like you used backslashes \ somewhere in your configuration instead of forward slashes / ?
Directories on linux always use / between the names. On Windows, at least in PHP, either forward or backward slashes work.
jondaley
Lifetype Expert
 
Posts: 6169
Joined: Thu May 20, 2004 6:19 pm
Location: Pittsburgh, PA, USA
LifeType Version: 1.2.11 devel branch

Postby phunkphorce on Wed Mar 21, 2007 7:25 am

Can you post it in http://bugs.lifetype.net? Just open a new issue for it and we'll integrate it in LifeType 1.2.1.

Regarding the issue you're having, I will give it a try later.
phunkphorce
Lifetype Expert
 
Posts: 9028
Joined: Mon Aug 25, 2003 6:34 am
Location: Suomessa

Postby xtremelead on Wed Mar 21, 2007 7:41 am

jondaley wrote:It looks like you used backslashes \ somewhere in your configuration instead of forward slashes / ?
Directories on linux always use / between the names. On Windows, at least in PHP, either forward or backward slashes work.

something must have changed in the latest release, because the 1.2 beta worked fine
xtremelead
 
Posts: 29
Joined: Fri May 12, 2006 1:14 am

Postby cactusman on Wed Mar 21, 2007 7:43 am

I have just posted the files in http://bugs.lifetype.net
Would be nice to have a look before to integrate it, just in case.

Hope you will find a wau for the problem
cactusman
 
Posts: 73
Joined: Sun Feb 25, 2007 4:55 am
Location: Japan
LifeType Version: 1.2.8

Postby jondaley on Wed Mar 21, 2007 9:10 am

Oh, you are on a windows machine. I don't know then.
I really doubt anything changed in lifetype recently having to do with this problem. Perhaps PHP was upgraded or something else changed on your host?
It won't get looked at unless you submit a bug report though.
jondaley
Lifetype Expert
 
Posts: 6169
Joined: Thu May 20, 2004 6:19 pm
Location: Pittsburgh, PA, USA
LifeType Version: 1.2.11 devel branch

Postby phunkphorce on Wed Mar 21, 2007 10:30 am

And even if you submit a bug-report, Windows-only problems are difficult to track because as far as I know none of us is running windows.
phunkphorce
Lifetype Expert
 
Posts: 9028
Joined: Mon Aug 25, 2003 6:34 am
Location: Suomessa

Postby cactusman on Wed Mar 21, 2007 10:31 am

Personnaly I got everything in local and everything still working perfectely with the beta version so there is necessary something different.
cactusman
 
Posts: 73
Joined: Sun Feb 25, 2007 4:55 am
Location: Japan
LifeType Version: 1.2.8

Next

Return to LifeType 2.0 Development

cron