Problem with final Release

Postby jondaley on Wed Mar 21, 2007 12:44 pm

And you are using the same database and all files are the same other than the changes from us?
jondaley
Lifetype Expert
 
Posts: 6169
Joined: Thu May 20, 2004 6:19 pm
Location: Pittsburgh, PA, USA
LifeType Version: 1.2.11 devel branch

Postby jondaley on Wed Mar 21, 2007 12:46 pm

What version is the "beta" version - what does version.php say?
Where did you get the beta package - I guess it has already been erased from the web site?
jondaley
Lifetype Expert
 
Posts: 6169
Joined: Thu May 20, 2004 6:19 pm
Location: Pittsburgh, PA, USA
LifeType Version: 1.2.11 devel branch

Postby cactusman on Wed Mar 21, 2007 1:20 pm

The beta version is lifetype-1.2-beta1_r4692
I download it on this website and installed it without modifications.
Even if I install it now it works perfectly.
So I still have the original lifetype-1.2-beta1_r4692 version on my computer.
I use an other database that I create but all the databases are in localhost anyway with Easy-PHP.
cactusman
 
Posts: 73
Joined: Sun Feb 25, 2007 4:55 am
Location: Japan
LifeType Version: 1.2.8

Postby xtremelead on Wed Mar 21, 2007 2:07 pm

my working beta is lifetype-1.2_r4882
same db, same php
xtremelead
 
Posts: 29
Joined: Fri May 12, 2006 1:14 am

Postby phunkphorce on Wed Mar 21, 2007 2:19 pm

Do you guys have access to a subversion client and are interested in helping us? The only thing related to templates that I can think of, and that was changed before 1.2 was released is Smarty. We upgraded the library to their latest version, as we were 2 versions behind.

If you're able to use the subversion client, it is possible to check out the code just before and just after we upgraded to the newest version of Smarty. If this problem does not appear in the code before the upgrade, but it appears in the code after the upgrade, then we can blame Smarty.

This command will get you the code from subversion before the Smarty upgrade:

Code: Select all
svn co -r 5110 http://devel.lifetype.net/svn/plog/plog/branches/lifetype-1.2


Now install this version like any other version of Lifetype and see if you still get the error.

When you're ready, type this command in the same folder where the previous version was installed:

Code: Select all
svn update -r 5111


Now clean the tmp/ folder, try again and see if the error appears again (or not)
phunkphorce
Lifetype Expert
 
Posts: 9028
Joined: Mon Aug 25, 2003 6:34 am
Location: Suomessa

Postby cactusman on Wed Mar 21, 2007 11:18 pm

Sorry I'm completely lost lol.
I open an acount in http://www.tigris.org/ and now what shall I do?
I never heard about subversion before sorry!

Ok I have downloaded wincvs but how can I use it in locale???
Last edited by cactusman on Thu Mar 22, 2007 1:37 am, edited 1 time in total.
cactusman
 
Posts: 73
Joined: Sun Feb 25, 2007 4:55 am
Location: Japan
LifeType Version: 1.2.8

Postby cactusman on Thu Mar 22, 2007 12:44 am

Ok I installed WinCVS but now I need to know how to get the files through the program. Can i be connected in anonymous and how to do that?

I also download Tortoise CVS but I can't get the file, I think I'm getting crazy lol.
cactusman
 
Posts: 73
Joined: Sun Feb 25, 2007 4:55 am
Location: Japan
LifeType Version: 1.2.8

Postby phunkphorce on Thu Mar 22, 2007 4:51 am

Never mind, I see that this was too complicated for you :)

I managed to get LT 1.2 installed and working in my work Windows computer (but don't tell my company, ok? :)) and was able to reproduce this error. I've checked in the changes needed to fix it in Lifetype 1.2.1 and I've uploaded a hotfix here:

http://bugs.lifetype.net/view.php?id=1226

It was definitely caused by the upgrade to the latest version of Smarty. Would you two be so kind to check the link above, download the attached file and follow the instructions posted there (instructions are on the bottom half of the link)

Let us know if the errors go away for you too.
phunkphorce
Lifetype Expert
 
Posts: 9028
Joined: Mon Aug 25, 2003 6:34 am
Location: Suomessa

Postby cactusman on Thu Mar 22, 2007 5:21 am

Wouhouuuu !

Works perfectly, thank you very much!
cactusman
 
Posts: 73
Joined: Sun Feb 25, 2007 4:55 am
Location: Japan
LifeType Version: 1.2.8

Postby xtremelead on Thu Mar 22, 2007 6:26 am

aaahhh...great stuff!
works fine for me too now!

thanks a million :D
xtremelead
 
Posts: 29
Joined: Fri May 12, 2006 1:14 am

Postby jondaley on Thu Mar 22, 2007 1:05 pm

good work -- I forgot that we upgraded a bunch of third party stuff right at the end.
jondaley
Lifetype Expert
 
Posts: 6169
Joined: Thu May 20, 2004 6:19 pm
Location: Pittsburgh, PA, USA
LifeType Version: 1.2.11 devel branch

Previous

Return to LifeType 2.0 Development

cron