Problem mit Galeriealben

Problem mit Galeriealben

Postby helga on Tue Mar 31, 2009 3:06 am

Hallo,

aus irgend einem Grund werden bei den Usern falsche Galerien angezeigt.
Der User hat z.b. die UserID 43 und die BlogID 137. Wenn er in sein Adminpanel geht, sieht er alle Alben des Users mit der UserID 137, anstatt sein. Woran kann das liegen?
Wenn ich dort nun ein neues Album anlege, wird in der Datenbank unter owner_id auch die 137 eingetragen ???
helga
 
Posts: 53
Joined: Mon Mar 02, 2009 2:14 pm
LifeType Version: 1.2.8

Re: Problem mit Galeriealben

Postby chromos on Tue Mar 31, 2009 2:37 pm

meinst du die owner_id in lt_gallery_albums? Falls ja, das ist die Id vom Blog und nicht vom User.
chromos
 
Posts: 274
Joined: Wed Mar 09, 2005 2:22 pm
LifeType Version: 1.2.9-devel

Re: Problem mit Galeriealben

Postby helga on Wed Apr 01, 2009 6:16 am

ja die meinte ich und ich schrieb ja oben, dass er die BlogID 137 hat, aber die Alben in der Galerie im Adminpanel des users mit der ID 137 sieht ? Wo könnte da der fehler liegen?
helga
 
Posts: 53
Joined: Mon Mar 02, 2009 2:14 pm
LifeType Version: 1.2.8

Re: Problem mit Galeriealben

Postby martinh on Wed Apr 01, 2009 8:00 am

Wenn der Blog die ID 137 hat, dann hat die Galerie auch die ID 137. Mit der User ID hat das nichts zu tun. Hast Du in der DB die IDs geändert?
martinh
 
Posts: 175
Joined: Wed Aug 01, 2007 7:32 am
Location: Heidelberg, Germany
LifeType Version: 1.2.11

Re: Problem mit Galeriealben

Postby helga on Wed Apr 01, 2009 9:40 am

in der Datenbank steht doch in der Tabelle lt_gallery_albums nichts von einer BlogID, sondern die owner_id. Anhand dieser OwnerID werden doch die Galeriealben des Users angezeigt, zumindestens sollten. Nur aus irgendwelchen Grund werden die Alben anhand der BlogID aus der DB geholt und ich weiß nicht warum.
Es geht nicht um den Ordner der Galerie, welcher den Namen der BlogID hat, sondern nur um den abruf aus der DB.
helga
 
Posts: 53
Joined: Mon Mar 02, 2009 2:14 pm
LifeType Version: 1.2.8

Re: Problem mit Galeriealben

Postby martinh on Wed Apr 01, 2009 10:03 am

Ich habe mir das mal bei mir angeschaut. Die owner_id ist identisch mit der Blog ID. In einem Blog waren mehrere Alben angelegt, die ID der Alben war unterschiedlich, aber die owner_id war dieselbe. Wenn der Blog also die ID 137 hat, dann muß die owner_id auch 137 haben. So ist es jedenfalls bei mir.
martinh
 
Posts: 175
Joined: Wed Aug 01, 2007 7:32 am
Location: Heidelberg, Germany
LifeType Version: 1.2.11

Re: Problem mit Galeriealben

Postby helga on Wed Apr 01, 2009 10:32 am

das ist bei dir dann mehr oder weniger Zufall, da jeder User dann immer nur ein Blog hat.
helga
 
Posts: 53
Joined: Mon Mar 02, 2009 2:14 pm
LifeType Version: 1.2.8

Re: Problem mit Galeriealben

Postby martinh on Wed Apr 01, 2009 10:42 am

Ich habe beispielsweise ein Blog mit fünf Bloggern. Dieser Blog hat sieben Alben. Die owner_id ist immer diesselbe wie die id bei der Tabelle lt_blogs. Die lt_blogs hat auch eine owner_id, aber das ist in diesem Falle der Blog Besitzer. Bei der lt_gallery_albums hingegen ist die owner_id die blog ID.
martinh
 
Posts: 175
Joined: Wed Aug 01, 2007 7:32 am
Location: Heidelberg, Germany
LifeType Version: 1.2.11

Re: Problem mit Galeriealben

Postby helga on Thu Apr 02, 2009 10:10 am

martinh wrote:Bei der lt_gallery_albums hingegen ist die owner_id die blog ID.


Das ist die BlogID dort??? Dann ist es kein Wunder, dass ich das dort nie geschnallt habe, was da genau abgeht. Wer kommt da auf die Idee, diese Spalte dann owner_id zu benennen, wenn es doch die BlogID ist ???
helga
 
Posts: 53
Joined: Mon Mar 02, 2009 2:14 pm
LifeType Version: 1.2.8

Re: Problem mit Galeriealben

Postby helga on Thu Apr 02, 2009 3:17 pm

durch die falsche Benennung dieser Spalte habe ich bei einer Migration die owner_id überall geändert, da alle user eine neue Userid bekommen haben und ich dort dann natürlich diese dort auch änderte. Man man man. :twisted:
helga
 
Posts: 53
Joined: Mon Mar 02, 2009 2:14 pm
LifeType Version: 1.2.8

Re: Problem mit Galeriealben

Postby martinh on Wed Apr 29, 2009 4:57 am

helga wrote:Wer kommt da auf die Idee, diese Spalte dann owner_id zu benennen, wenn es doch die BlogID ist ???


Ich glaube die Logik ist, daß die Alben zum Blog gehören, der Blog also der Besitzer der Alben ist.
Hast Du denn bei Dir alles wieder in Ordnung gebracht?
martinh
 
Posts: 175
Joined: Wed Aug 01, 2007 7:32 am
Location: Heidelberg, Germany
LifeType Version: 1.2.11

Re: Problem mit Galeriealben

Postby helga on Sat May 09, 2009 10:34 am

Ich glaube die Logik ist, daß die Alben zum Blog gehören, der Blog also der Besitzer der Alben ist.


trotzdem hätte man dort BlogID als Name nutzen können, um sich auch in der DB besser zurecht finden zu können.

Bisher kamen auf jeden Fall keine weiteren Beschwerden mehr, von daher gehe ich davon aus, dass wieder alles im grünen Bereich ist.
helga
 
Posts: 53
Joined: Mon Mar 02, 2009 2:14 pm
LifeType Version: 1.2.8


Return to German

cron