Problem with the ice template

Problem with the ice template

Postby Homeless on Tue Dec 18, 2007 5:45 am

I'm using lifetype 1.2.5 and ice template and noticed that when clicking comment on a post, it doesn't do anything. Anyone know how to fix this?
Homeless
 
Posts: 10
Joined: Sat Dec 08, 2007 8:00 am

Postby Homeless on Tue Dec 18, 2007 5:55 am

I should also note that this only applies when the post has 0 comments. If a comment already exists the problem is not evident.
Homeless
 
Posts: 10
Joined: Sat Dec 08, 2007 8:00 am

Postby ogd39 on Tue Dec 18, 2007 11:24 am

Hello!
Do you get any error?
LT version installed : 1.2.6
ogd39
 
Posts: 287
Joined: Thu Jun 15, 2006 5:19 pm
Location: France

Postby Homeless on Tue Dec 18, 2007 11:26 am

there's no error, the only thing that happens is that a blank page loads.
Homeless
 
Posts: 10
Joined: Sat Dec 08, 2007 8:00 am

Postby jondaley on Tue Dec 18, 2007 11:53 pm

I see that. I am not sure what the CommentLink function is supposed to be doing - I didn't know it existed.

I see that ice is the only one that is using it. Can you please report this to bugs.lifetype.net, so someone can fix it? I think the fix is simply to remove that function call from the post.template.

Hrm - I see the postReplyCommentLink in postandcomments.template - that is more useful, so you'll want to check to see if that also causes an error.

Maybe the point of the CommentLink is so you could have comments on a separate page, like some blogs do, rather than having the comment form on the same page as the article text. I personally think that is annoying, but probably some people like it that way.
jondaley
Lifetype Expert
 
Posts: 6169
Joined: Thu May 20, 2004 6:19 pm
Location: Pittsburgh, PA, USA
LifeType Version: 1.2.11 devel branch

Postby Homeless on Wed Dec 19, 2007 1:42 am

Just submitted it to the bug page.
Homeless
 
Posts: 10
Joined: Sat Dec 08, 2007 8:00 am

Re: Problem with the ice template

Postby jondaley on Thu May 01, 2008 3:09 pm

It turns out it wasn't a template error, but a core code problem. See the bug report for details and the file to upgrade your 1.2.7 installation.
jondaley
Lifetype Expert
 
Posts: 6169
Joined: Thu May 20, 2004 6:19 pm
Location: Pittsburgh, PA, USA
LifeType Version: 1.2.11 devel branch


Return to Templates

cron