Error 500 URL personales

Error 500 URL personales

Postby disecor on Sat Dec 29, 2007 8:23 am

He estado leyendo sobre esto, pero no encuentro la solución.

Ya que no puedo poner subdominios, he decidido trabajar con URLS personales.

Ahora bien. tengo la web en http://www.nombredelaweb.com/lifetype

Si pongo trabajar con URLS personales, me sale el error 500
Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webmaster@sinchubasquero.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.


¿A que se puede deber?
disecor
 
Posts: 11
Joined: Fri Dec 28, 2007 5:26 pm

Re: Error 500 URL personales

Postby jondaley on Sat Dec 29, 2007 10:22 am

disecor wrote:More information about this error may be available in the server error log.

Verifique el tronco Apache del error.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

http://wiki.lifetype.net/index.php/Inst ... stallation
jondaley
Lifetype Expert
 
Posts: 6169
Joined: Thu May 20, 2004 6:19 pm
Location: Pittsburgh, PA, USA
LifeType Version: 1.2.11 devel branch

Postby disecor on Sat Dec 29, 2007 12:38 pm

Sigue sin funcionar.

He echo cambios. Ahora el lifetype se encuentra en el directorio raiz, pero sigue habiendo los mismos fallos.

Error-log

[29-Dec-2007 10:23:07] PHP Warning: mysql_pconnect() [<a href='function.mysql-pconnect'>function.mysql-pconnect</a>]: Access denied for user 'sinchuba'@'localhost' (using password: NO) in /home/sinchuba/public_html/class/database/pdb/drivers/pdbmysqldriver.class.php on line 103
[29-Dec-2007 10:23:07] PHP Warning: mysql_error(): supplied argument is not a valid MySQL-Link resource in /home/sinchuba/public_html/class/database/pdb/drivers/pdbmysqldriver.class.php on line 133
[29-Dec-2007 10:23:07] PHP Fatal error: Uncaught exception 'Exception' with message 'Fatal error: could not connect to the database! Error: ' in /home/sinchuba/public_html/class/database/db.class.php:76
Stack trace:
#0 /home/sinchuba/public_html/class/config/configdbstorage.class.php(83): Db->getDb()
#1 /home/sinchuba/public_html/class/config/configdbstorage.class.php(63): ConfigDbStorage->_initializeDatabase()
#2 /home/sinchuba/public_html/class/config/configdbstorage.class.php(56): ConfigDbStorage->_loadAllValuesFromDatabase()
#3 /home/sinchuba/public_html/class/config/config.class.php(103): ConfigDbStorage->ConfigDbStorage(NULL)
#4 /home/sinchuba/public_html/error.php(32): Config::getConfig()
#5 {main}



Htaccess.

<Files .htaccess>
deny from all
</Files>

<Files config.properties.php>
deny from all
</Files>

Options -Indexes
Options +FollowSymLinks

<IfModule mod_rewrite.c>

RewriteEngine On
RewriteBase /

# Permalink to the blog entry (i.e. /1_userfoo/archive/3_title-foo-bar.html)
RewriteRule ^([0-9]+)_[^/]+/archive/([0-9]+)_[^.]+\.html$ index.php?op=ViewArticle&blogId=$1&articleId=$2 [L,NC]

# Monthly archive (i.e. /1_userfoo/archive/200401.html)
RewriteRule ^([0-9]+)_[^/]+/archive/([0-9]{6})\.html$ index.php?blogId=$1&Date=$2 [L,NC]
# -- same as above but with paging included
RewriteRule ^([0-9]+)_[^/]+/archive/([0-9]{6})\.html\.page\.([1-9]+)$ index.php?blogId=$1&Date=$2&page=$3 [L,NC]

# Daily archive (i.e. /1_blogfoo/archive/20040101.html)
RewriteRule ^([0-9]+)_[^/]+/archive/([0-9]{8})\.html$ index.php?blogId=$1&Date=$2 [L,NC]
# -- same as above but with paging included
RewriteRule ^([0-9]+)_[^/]+/archive/([0-9]{8})\.html\.page\.([1-9]+)$ index.php?blogId=$1&Date=$2&page=$3 [L,NC]

# Album (i.e. /88_userfoo/albums/34_title-foo-bar.html)
RewriteRule ^([0-9]+)_[^/]+/albums/([0-9]+)_[^.]+\.html$ index.php?op=ViewAlbum&blogId=$1&albumId=$2 [L,NC]
# -- same as above but with paging included
RewriteRule ^([0-9]+)_[^/]+/albums/([0-9]+)_[^.]+\.html\.page\.([1-9]+)$ index.php?op=ViewAlbum&blogId=$1&albumId=$2&page=$3 [L,NC]

# Albums (i.e. /88_userfoo/albums/)
RewriteRule ^([0-9]+)_[^/]+/albums/$ index.php?op=ViewAlbum&blogId=$1&albumId=0 [L,NC]

# Category view (i.e. /88_userfoo/categories/4_cat-foobar.html)
RewriteRule ^([0-9]+)_[^/]+/categories/([0-9]+)_[^.]+\.html$ index.php?blogId=$1&postCategoryId=$2 [L,NC]
# -- same as above but with paging included
RewriteRule ^([0-9]+)_[^/]+/categories/([0-9]+)_[^.]+\.html\.page\.([1-9]+)$ index.php?blogId=$1&postCategoryId=$2&page=$3 [L,NC]

# Category-Feeds (i.e. /3_userfoo/feeds/categories/2_category/atom)
RewriteRule ^([0-9]+)_[^/]+/feeds/categories/([0-9]+)_[^.]+/(.*)$ rss.php?blogId=$1&categoryId=$2&profile=$3 [L,NC]

# Feeds (i.e. /3_userfoo/feeds/atom)
RewriteRule ^([0-9]+)_[^/]+/feeds/(.*)$ rss.php?blogId=$1&profile=$2 [L,NC]

# Trackbacks (i.e. /3_userfoo/trackbacks/34_title-foo-bar.html)
RewriteRule ^([0-9]+)_[^/]+/trackbacks/([0-9]+)_[^.]+\.html$ index.php?op=Trackbacks&blogId=$1&articleId=$2 [L,NC]

# Comment form (i.e. /88_userfoo/comment/34_title-foo-bar.html)
RewriteRule ^([0-9]+)_[^/]+/comment/([0-9]+)_[^.]+\.html$ index.php?op=Comment&blogId=$1&articleId=$2 [L,NC]

# Resources (i.e. /88_userfoo/resources/this-is-a-resource-name.pdf.html)
RewriteRule ^([0-9]+)_[^/]+/resources/([^.]+)\.([^.]+)\.html$ index.php?op=ViewResource&blogId=$1&resource=$2.$3 [L,NC]

# Download a resource (i.e. /88_userfoo/get/this-is-a-resource-name.pdf)
RewriteRule ^([0-9]+)_[^/]+/get/(.+)$ resserver.php?blogId=$1&resource=$2 [L,NC]

# A non-default blog (i.e. /88_userfoo)
RewriteRule ^([0-9]+)(_[^/]+)?$ index.php?blogId=$1 [L,NC]
# -- same as above but with paging included
RewriteRule ^([0-9]+)(_[^/]+)\.page\.([1-9]+)$ index.php?blogId=$1&page=$3 [L,NC]

# Static Pages (i.e /3_userfoo/demosites)
RewriteRule ^([0-9]+)_[^/]+/(.+)$ index.php?op=Template&blogId=$1&show=$2 [NC]

</IfModule>





¿Dónde puede estar el error?

Repito que ahora se encuentra en el directorio raiz del sitio.

Saludos
disecor
 
Posts: 11
Joined: Fri Dec 28, 2007 5:26 pm

Postby disecor on Sun Dec 30, 2007 12:04 pm

Siguiendo con los cambios....

Pongo URLs Personales y en la dirección, quito la parte donde pone /blog.
De esta forma consigo http://www.sinchubasquero.com/sinchubasquero

Ahora ya no sale el mensaje de error 500, pero si sales al blog, le des a donde le des, siempre sale la misma página.

Al estar la web en el directorio raiz en el htaccess configurado de la siguiente manera.

ErrorDocument 401 /error.php
ErrorDocument 403 /error.php
ErrorDocument 404 /error.php

Estoy venga a leer en foros, pero no encuentro la solución.
No se si me podreis echar una mano...

Muchas gracias.
disecor
 
Posts: 11
Joined: Fri Dec 28, 2007 5:26 pm

Postby jondaley on Tue Jan 01, 2008 12:40 am

Sorry - tried to help you in Spanish, but I think my translation skills are done...

You'll probably have to wait for a Spanish speaker to help you out.

My recommendation is to get "plain URLs" working first, and then switch to "custom URLs".
jondaley
Lifetype Expert
 
Posts: 6169
Joined: Thu May 20, 2004 6:19 pm
Location: Pittsburgh, PA, USA
LifeType Version: 1.2.11 devel branch


Return to Español

cron